Instalacja LV 2016 DS2

Jeśli masz coś do powiedzenia w sprawie LabVIEW napisz. Tutaj są tematy, których nie można uściślić do innych działów.
spalinowy
Posty: 82
Rejestracja: 03 lut 2012 15:09
Wersja środowiska: LabVIEW 2016
Lokalizacja: Warszawa
Kontakt:

Instalacja LV 2016 DS2

Post autor: spalinowy » 18 mar 2017 10:23

Witam,

mam pewien kłopot z instalacją najnowszej wersji LabVIEW. Otóż na jednym kompie (z Win 8.1) instalowałem cały pakiet bez problemu, natomiast na kolejnym (też Win 8.1) już się zaczęły schody. Pojawia mi się informacja jak w oknie poniżej. Jak to jest, że na jednym kompie wszystko poszło a na drugim nie? Jedyna różnica to czas instalacji czyli na jednym było to w grudniu a na drugim teraz staram się to zrobić.
I teraz też nie wiem jak to będzie z pracą nad projektem na 2 kompach lub jego uruchamianiem.
A co będzie na przyszłość, powinienem siedzieć na Win 7 aby było ok? Jak będzie w takim razie w przyszłości kiedy LV nie będzie wspierało starszych systemów?
Załączniki
Błąd instalacji.png
Błąd instalacji.png (128.42 KiB) Przejrzano 1242 razy

PiDi
Posty: 602
Rejestracja: 31 gru 2010 01:36
Wersja środowiska: LabVIEW 2014
Lokalizacja: Katowice
Has thanked: 2 times
Been thanked: 1 time

Re: Instalacja LV 2016 DS2

Post autor: PiDi » 18 mar 2017 14:25

Kompilatory ISE są potrzebne do tylko starszych targetów FPGA. Nowsze używają Vivado, który wspiera Win>7. Tu jest tabelka: http://www.ni.com/product-documentation/53056/en/ - przy czym należy zwrócić też uwagę na Notes pod tabelką.

Podstawowe pytanie do Ciebie brzmi: jaki target FPGA masz w projekcie?
ObrazekObrazekObrazek

spalinowy
Posty: 82
Rejestracja: 03 lut 2012 15:09
Wersja środowiska: LabVIEW 2016
Lokalizacja: Warszawa
Kontakt:

Re: Instalacja LV 2016 DS2

Post autor: spalinowy » 18 mar 2017 15:09

Ale co z kompilatorem w przypadku nowszego systemu jak 8.1? Instaluję LV 2016, ale bez Xilinx nie da się zainstalować FPGA. A żeby móc używać FPGA na starszym urządzeniu, to mam instalować starszego Xilinxa i już nowsze FPGA?
Akurat mam z tych starszych - cRIO 9022 i Chassis 9114

PiDi
Posty: 602
Rejestracja: 31 gru 2010 01:36
Wersja środowiska: LabVIEW 2014
Lokalizacja: Katowice
Has thanked: 2 times
Been thanked: 1 time

Re: Instalacja LV 2016 DS2

Post autor: PiDi » 18 mar 2017 20:56

Ok, to do 9114 potrzebujesz ISE. Sam kompilator (Compile Server + Worker) da się zainstalować na innym komputerze z innym systemem i tam robić kompilację (http://www.ni.com/white-paper/11573/en/). Natomiast co do instalacji modułu FPGA bez Xilinxa - nie wiem, czy i jak to zrobić. Polecam w takim razie bilecik na techsupport@ni.com, tam najszybciej pomogą.
ObrazekObrazekObrazek

spalinowy
Posty: 82
Rejestracja: 03 lut 2012 15:09
Wersja środowiska: LabVIEW 2016
Lokalizacja: Warszawa
Kontakt:

Re: Instalacja LV 2016 DS2

Post autor: spalinowy » 21 mar 2017 12:46

Kończąc temat opiszę w paru słowach rozwiązanie.

Wsparcie dla Xilinxa jest wstrzymane, ale czasowo, bo nie został przetestowany we współpracy ze wszystkimi pakietami na nowych systemach. Nie wiem jedynie kiedy się spodziewać już full version działającego dla Win 8+.
Instalację załatwiłem tak, że pobrałem starszą wersję Xilinxa i zainstalowałem. Potem pobrałem pakiet FPGA, bo z płytki jakoś mi nie chciało złapać FPGA.
Tyle w temacie.

TMa
Posty: 198
Rejestracja: 07 sty 2010 12:56
Wersja środowiska: LabVIEW 2017
Been thanked: 3 times

Re: Instalacja LV 2016 DS2

Post autor: TMa » 21 mar 2017 13:22

FYI:
National Instruments Product Compatibility for Microsoft Windows 8
The Xilinx tools used by the FPGA Module do not officially support Windows 8.

Awatar użytkownika
skoziate
NI Man
Posty: 243
Rejestracja: 06 mar 2007 00:00
Wersja środowiska: LabVIEW 2014
Lokalizacja: Warszawa
Kontakt:

Instalacja LV 2016 DS2

Post autor: skoziate » 22 mar 2017 11:50

Sam osobiście nie sprawdzałem, ale swojego czasu szukając rozwiązania natknąłem się na to: http://www.eevblog.com/forum/microcontr ... -8-64-bit/
Pozdrawiam,
Sebastian

ODPOWIEDZ