Zakłócenia 10Hz

Wszelkie sprawy związane z LabVIEW i komunikacją ze sprzętem. Problemy i ciekawe rozwiązania.
mwojcie3
Posty: 26
Rejestracja: 07 sty 2015 07:05
Wersja środowiska: LabVIEW 2013

Zakłócenia 10Hz

Post autor: mwojcie3 » 22 sty 2018 10:28

Witam

Jestem w trakcie realizacji jak dla mnie dość złożonego projektu. Podczas pomiarów pojawiając się zakłócenia o częstotliwości 10 Hz, za cholerę nie mogę dojść skąd się mogą one pojawiać. Przewód pomiarowy jest nie ekranowany, więc łapie pewnie wszystko :(.

W załączniku zrzut ekranu ze zmierzonych sygnałów.
Załączniki
zaklocenia.jpg

spalinowy
Posty: 106
Rejestracja: 03 lut 2012 15:09
Wersja środowiska: LabVIEW 2017
Lokalizacja: Warszawa
Been thanked: 3 times
Kontakt:

Re: Zakłócenia 10Hz

Post autor: spalinowy » 22 sty 2018 18:38

No niestety, ale z zakłóceniami musisz sobie poradzić sam. Ani nie wiem nic o aparaturze jakiej używasz, ani o otoczeniu pomiarowym, które może generować zakłócenia. Na tym etapie to wróżenie z fusów.

Awatar użytkownika
jogurt_owocowy
Posty: 1316
Rejestracja: 30 lis 2004 00:00
Wersja środowiska: LabVIEW 2015
Lokalizacja: Kraków
Been thanked: 1 time
Kontakt:

Re: Zakłócenia 10Hz

Post autor: jogurt_owocowy » 22 sty 2018 20:41

Podczas pomiarów pojawiając się zakłócenia o częstotliwości 10 Hz, za cholerę nie mogę dojść skąd się mogą one pojawiać.
Dawno temu był na forum podobny temat: Spektrum mocy - problemy.

PiDi
Posty: 627
Rejestracja: 31 gru 2010 01:36
Wersja środowiska: LabVIEW 2017
Lokalizacja: Katowice
Has thanked: 3 times
Been thanked: 3 times

Re: Zakłócenia 10Hz

Post autor: PiDi » 22 sty 2018 22:59

To może być jakiś błąd programowy, typu inicjalizowanie jakiegoś filtru zamiast ciągłej filtracji. Ale równie dobrze coś może faktycznie siać po przewodach. Pokaż kod, przede wszystkim ten, który odpowiada za pomiar.
ObrazekObrazekObrazekObrazek

mwojcie3
Posty: 26
Rejestracja: 07 sty 2015 07:05
Wersja środowiska: LabVIEW 2013

Re: Zakłócenia 10Hz

Post autor: mwojcie3 » 07 lut 2018 13:43

Kod całego programu w załączniku.
Jest dość skomplikowany, więc wszystkie pliki zapuszczam. Pętla pomiarowa w folderze Loops/Acquisition Message Loop.
Dzięki za pomoc.
Załączniki
Stoisko.rar
(1.4 MiB) Pobrany 107 razy

mwojcie3
Posty: 26
Rejestracja: 07 sty 2015 07:05
Wersja środowiska: LabVIEW 2013

Re: Zakłócenia 10Hz

Post autor: mwojcie3 » 07 lut 2018 13:50

Zaekranowałem przewody. Niestety raz są szpilki a raz ich nie ma. Jest to zjawisko strasznie nie powtarzalne.
1.jpg
2.jpg

mwojcie3
Posty: 26
Rejestracja: 07 sty 2015 07:05
Wersja środowiska: LabVIEW 2013

Re: Zakłócenia 10Hz

Post autor: mwojcie3 » 19 cze 2018 09:09

Niestety zakłócenia to nie kończąca się opowieść. Teraz mam takie cuda. Gdy nie przełączam cewek nie ma ich, gdy zaczynam przełączać cewki, pojawia się magia :(. Najgorsze że są one bardzo nieregularne i nie wiem czemu mają taki kształt. Może ktoś pomóc?
Załączniki
20180618_152300.jpg

mwojcie3
Posty: 26
Rejestracja: 07 sty 2015 07:05
Wersja środowiska: LabVIEW 2013

Re: Zakłócenia 10Hz

Post autor: mwojcie3 » 19 cze 2018 09:26

Poglądowy schemat połączeń poniżej.
Załączniki
20180619_092333.jpg

Awatar użytkownika
micard
Posty: 180
Rejestracja: 30 wrz 2011 11:28
Wersja środowiska: LabVIEW 2016
Has thanked: 6 times
Been thanked: 6 times
Kontakt:

Re: Zakłócenia 10Hz

Post autor: micard » 20 cze 2018 12:45

5m nieekranowanego kabla i cewki... to niestety nie mogło wyjść inaczej

mwojcie3
Posty: 26
Rejestracja: 07 sty 2015 07:05
Wersja środowiska: LabVIEW 2013

Re: Zakłócenia 10Hz

Post autor: mwojcie3 » 20 cze 2018 15:53

Problem w tym że teraz mam kilka kabli ekranowanych. Kabel od cewek jest ekranowany, kable od czujników, pomiaru zasilania i puszczone są razem równolegle tworząc kabel o długości 5 metrów, prowizorycznie połączone taśmą izolacyjną aby tworzyły jedną wiązkę. Nie zaznaczyłem na szkicu, sroki.

Wcześniej miałem długi kabel wielożyłowy, ale wszystko w jednym wspólnym ekranie, ale siało wszędzie :( i podzieliłem na kilka kabli ekranowanych o mniejszej liczbie przewodów.

Awatar użytkownika
micard
Posty: 180
Rejestracja: 30 wrz 2011 11:28
Wersja środowiska: LabVIEW 2016
Has thanked: 6 times
Been thanked: 6 times
Kontakt:

Re: Zakłócenia 10Hz

Post autor: micard » 20 cze 2018 22:47

niestety tutaj zaczyna się "magia EMC". Bardzo ważne jest to z której strony kabla i do jakiej "masy" podpięty jest ekran.
Niestety cewki to wredne bestie - szczególnie jeśli załączane są przekaźnikami.

kali
Posty: 14
Rejestracja: 22 wrz 2011 14:27
Wersja środowiska: LabVIEW 2017

Re: Zakłócenia 10Hz

Post autor: kali » 22 cze 2018 08:52

Hej
To i ja dorzucę coś od siebie :)
1. Czy ekrany przewodów podłączasz tylko z jednej strony ( mam nadzieje że tak)
2. Jakiego rodzaju jest podłączenie ekranu lutowane czy skręcane? Popraw połączenia ekranów zalutuj jeszcze raz jeżeli jest to połączenie trwałe lub oczyść drobnym papierem ściernym typu 600, 800 jeżeli jest skręcane.
3. Rozdziel linie zasilające i sygnałowe tak by nie szły równolegle blisko siebie.
4. Czy po drodze od czujników do karty pomiarowej masz jakieś obwody drukowane? Jeżeli tak do wstaw je w obudowy metalowe i umaś.
5. W jakim środowisku robisz pomiary? Tak jak napisał Micard jeżeli w okolicy masz jakieś duże źródło zakłóceń jak np. silnik to może być konieczne zastosowanie filtrów na zasilaniu układu pomiarowego. U mnie w pracy jest tak, że jak chłopaki za ścianą bawią się generatorami to u mnie na kablach pojawia się do 30 V ot tak i jakieś 2,5 kHz.

Jakbyś mógł to zrób zdjęcia układu pomiarowego może to ułatwi znalezienie przyczyny. :)

Awatar użytkownika
smiga
Posty: 693
Rejestracja: 04 paź 2009 12:41
Wersja środowiska: LabVIEW 2016
Lokalizacja: Słupsk
Has thanked: 4 times
Been thanked: 1 time
Kontakt:

Re: Zakłócenia 10Hz

Post autor: smiga » 22 cze 2018 10:14

Terminacja linii na obu końcach też może pomóc - rezystory około 100 Ohm (podpinasz jak obciążenie na końcu linii). Ewentualnie 1K-10KOhm jeżeli nie możesz mocno obciążyć linii ...możesz podciągnąć linię takim rezystorem do + zasilania... lub do masy (też na obu końcach). Celem jest dopasowanie linii, czyli eliminacja zjawisk "linii długiej" (odbicia itp.).
__ Arkadiusz Śmigielski, tel. 662 01 01 74___
ObrazekObrazekObrazek

ODPOWIEDZ