FPGA serwomechanizm - Problem - proszę o pomoc

Tematy związane z LabVIEW FPGA oraz programowaniem układów.
mad10
Posty: 4
Rejestracja: 22 gru 2012 10:50
Wersja środowiska: LabVIEW 2011

FPGA serwomechanizm - Problem - proszę o pomoc

Post autor: mad10 » 06 sty 2013 11:22

Witam,
Napisałem o to taki krótki program w FPGA, który ma sterować serwomechanizmem.
Bez tytułu1.jpg
Niestety serwem nie potrawie sterować ;/ Jeśli czas podam w sekundach a nie w milisekundach mogę ładnie na mierniku zobaczyć jak zmienia się impuls.
Posiadam Ni cRIO9022, Chassi 9114, oraz kartę NI 9403.
Serwo zasilam zasilaczem 5V i sygnałem z karty NI9403.
Czy wina może polegać że karta jaką posiadam jest nieodpowiednia do tego? Bo przecież program działa jak to można zobaczyć zmieniając na sekundy czas.
Pojawia mi się jeszcze problem:
Run when loaded to FPGA: FALSE
Bez tytułu3.jpg
Musze jakieś oprogramowanie jeszcze dodatkowo zainstalować, czy może coś w opcjach pozmieniać?

Dziękuje.

Awatar użytkownika
trooper
Posty: 22
Rejestracja: 22 paź 2012 17:44
Wersja środowiska: LabVIEW 2012
Kontakt:

Re: FPGA serwomechanizm - Problem - proszę o pomoc

Post autor: trooper » 06 sty 2013 20:34

Witam

Zacznę od końca ... Twój ostatni problem to nie problem tylko ustawienie programu. Po włączeniu programu strzałką RUN kod w FPGA uruchomi się. Obecne ustawienie mówi o tym, że po wgraniu programu nie uruchomi się "od razu" tylko na prośbę - np wciśnięcie przycisku lub przez uruchomienie metody RUN. I to jest jak najbardziej OK.

Poza tym piszesz, że przy ustawieniu czasu w programie w sekundach na mierniku widzisz zmianę ... a przy ustawieniu czasu w mikrosekundach na mierniku nie widzisz zmian ? :-\ dziwne ... :-? a może masz oscyloskop żeby potwierdzić brak zmiany?

Nie wiem czy nazwałbym już ten program programem do sterowania silnikiem. Póki co widzę, że jest to generowanie zer i jedynek na zmianę. Domyślam się też, że chciałeś uzyskać PWM. Jeżeli tak chciałeś - to niestety troche kiepskie rozwiązanie, ale zadziała ostatecznie. Dzisiaj nie napiszę już lepszego, ale napisz na przyszlość co chcesz uzyskać.
Proponuję, co najmniej, zrób nie dwie a 4 ramki sekwencji i w pierwszej i trzeciej zmień stan a w drugiej i czwartej ustaw czekanie.

Wybacz też dociekliwość, ale widzę nie pierwszy już post tego typu - problem studencki na cRIO. Czy mogę zapytać na jakiej uczelni jest on realizowany?

Pozdrawiam

mad10
Posty: 4
Rejestracja: 22 gru 2012 10:50
Wersja środowiska: LabVIEW 2011

FPGA serwomechanizm - Problem - proszę o pomoc

Post autor: mad10 » 07 sty 2013 17:45

Witam,

Chciałem uzyskać sterowanie serwomechanizmem. Tak jak na danym linku poniżej:
http://hobby.abxyz.bplaced.net/img/art020_07.jpg
Mam też taki program na 4 ramki:

http://dl.dropbox.com/u/133288431/serwo1.jpg
Program działa tak że ustawia 0 czeka 20ms potem podaje 1 i czeka od 1-2ms wzalezności jaką wartość ustawie.
Albo:
http://dl.dropbox.com/u/133288431/serwo1.jpg
Jest petla która powtarza się co 20ms oraz zmienia sie 0 na 1 i 1 na 0 wzaleznosci od ustawienia Count.
Albo:
http://dl.dropbox.com/u/133288431/serwo3.jpg
ALe tu jest znowu błąd że nie chce wgrać programu ze względu na obliczenia reszty.

Żaden ten program jakoś nie chce zadziałać. Daje na strzałke RUN program się wysyła pisze complied ale nic ;/
Serwo stoi w miejscu.
I pisze też ciągle:
Run when loaded to FPGA: FALSE

ODPOWIEDZ