HC - SR04 cRio

Tematy związane z LabVIEW FPGA oraz programowaniem układów.
Majo
Posty: 2
Rejestracja: 28 gru 2012 18:57
Wersja środowiska: LabVIEW 2011

HC - SR04 cRio

Post autor: Majo » 28 gru 2012 20:06

Witam,
jestem w trakcie budowy ultradźwiękowego czujnika sterowanego za pomocą LabVIEW 2012, jestem nowym użytkownikiem LabVIEW i mam problem . Mam dostęp do cRio 9022 oraz modułów NI 9423 oraz 9474. Pomiar ma się odbywać za pomocą czujnika HC - SR04. Problem jest w tym, że nie działa tak jak powinien. Nie wiem czy jest to wina algorytmu czy sprzętu. Posiadam 3 takie czujniki i na żadnym nie uzyskałem pomiaru odległości. Problem tkwi w wysyłaniu bądź odbiorze ultradźwięków, nie wiem tylko czy jest to wina czujnika czy urządzenia. Czy algorytm sterujący jest ok? Dodam, że musiałem modyfikować układ by podwyższał sygnał echo do 15V, ponieważ moduł NI9423 stan 5V traktował jako niski.
Pozdrawiam
Załączniki
LabView 2012.rar
Projekt czujnika
(202.08 KiB) Pobrany 160 razy

dzojstik22
Posty: 103
Rejestracja: 17 gru 2011 21:33
Wersja środowiska: LabVIEW 2011

Re: HC - SR04 cRio

Post autor: dzojstik22 » 29 gru 2012 00:53

Jak możesz to zapisz to we wcześniejszej wersji. Walczę z tym czujnikiem od dawna- chętnie połączę siły. Co prawda ja go podpinam do arduino ale wydaje mi się, że schemat blokowy będzie prawie taki sam.

Majo
Posty: 2
Rejestracja: 28 gru 2012 18:57
Wersja środowiska: LabVIEW 2011

Re: HC - SR04 cRio

Post autor: Majo » 29 gru 2012 01:39

Nie jestem pewien, czy to działa. Na dzień dzisiejszy nie potrafię zweryfikować czy problem jest sprzętowy czy z oprogramowaniem (stawiam raczej na oprogramowanie :P)
Załączniki
2011.rar
LV 2011
(41.17 KiB) Pobrany 163 razy

ODPOWIEDZ