programy exe i web server

Tematyka związana z Aplication Builderem oraz tworzeniem wersji exe programów w LabVIEW. Problemy związane z instalatorem programów oraz ich zabezpieczaniem.
mikema72
Posty: 72
Rejestracja: 09 sty 2006 00:00
Wersja środowiska: LabVIEW 2011
Lokalizacja: Gliwice

programy exe i web server

Post autor: mikema72 » 11 wrz 2008 13:11

Proszę o pomoc w rozwiązaniu mojego problemu z web serwerem. Otóż napisałem program (labVIEW 8.5) i skompilowałem go do exe. Następnie stworzyłem instalatora i jest cacy :). Wszystko działa...ale. Chciałem teraz dodać opcję podglądu działania tego programu użytkownikom z zewnątrz (tylko obserwacji). Problem w tym, że z tego co udało mi się wywnioskować z różnych pomocy, można to zrobić bezproblemowo jeżeli ma się vija nie skompilowanego i możliwość uruchamiania serwera z pod tego vija itd. Jak takie coś zrobić w moim przypadku. Co i jak dodać do setup i do wersji kompilowanej żeby się samo uruchamiało po zainstalowaniu i otwarciu programu. A jeszcze na dodatek żeby na komputerze u "podglądacza" oprócz np. Firefoxa nie trzeba było nic instalować. Mam nadzieję że nie zamieszałem i że ktoś mi pomoże...:)

Awatar użytkownika
wino
Posty: 548
Rejestracja: 23 gru 2005 00:00
Wersja środowiska: Nie mam LabVIEW
Lokalizacja: Kraków

Re: programy exe i web server

Post autor: wino » 11 wrz 2008 14:25


mikema72
Posty: 72
Rejestracja: 09 sty 2006 00:00
Wersja środowiska: LabVIEW 2011
Lokalizacja: Gliwice

Re: programy exe i web server

Post autor: mikema72 » 12 wrz 2008 12:08

=D> :D/ Dzięki!

mikema72
Posty: 72
Rejestracja: 09 sty 2006 00:00
Wersja środowiska: LabVIEW 2011
Lokalizacja: Gliwice

Re: programy exe i web server

Post autor: mikema72 » 06 sty 2009 11:58

Wracam do tematu. :help:
Wszystko działało cacy wg opisu wina dopóki nie zakupiłem nowego LabView 8.6. I zaczęły się schody.... :-k Czy coś jest nie tak z tą wersją, a może teraz robi się to inaczej, bo wg tego opisu wyskakuje mi tylko komunikat w przeglądarce : Access Error: 404 -- Not Found Nawet dla programów które kiedyś działały w wersjach wcześniejszych.
Proszę o pomoc. Sprawdźcie może u siebie....

mikema72
Posty: 72
Rejestracja: 09 sty 2006 00:00
Wersja środowiska: LabVIEW 2011
Lokalizacja: Gliwice

programy exe i web server

Post autor: mikema72 » 07 sty 2009 12:15

Nikt mi nie pomoże???

Awatar użytkownika
Mikrobi
Posty: 1210
Rejestracja: 08 paź 2003 00:00
Wersja środowiska: LabVIEW 2014
Lokalizacja: United Kingdom

programy exe i web server

Post autor: Mikrobi » 07 sty 2009 13:09

Czy próbowaleś ten sam kod kompilować do exe na 8.6?
Czy w pliku ini exeka są ustawione prawa dostepu ?
pozdrawiam
Mikrobi

LabVIEW Champion, CLD, CPI

Awatar użytkownika
wino
Posty: 548
Rejestracja: 23 gru 2005 00:00
Wersja środowiska: Nie mam LabVIEW
Lokalizacja: Kraków

Re: programy exe i web server

Post autor: wino » 07 sty 2009 18:30

nie wiem jak to jest teraz, ale ktoś mi mówił, że ktoś mu mówił z Nationala, że w 8.6 to ma być jakaś Java w Web Publishing Tool, czyli mogło się coś znacznie pozmieniać. Trzeba poszukać na ni.com i tam na pewno znajdziesz odpowiedź.
http://zone.ni.com/devzone/cda/tut/p/id/7350
Ostatnio zmieniony 07 sty 2009 18:35 przez wino, łącznie zmieniany 1 raz.

mikema72
Posty: 72
Rejestracja: 09 sty 2006 00:00
Wersja środowiska: LabVIEW 2011
Lokalizacja: Gliwice

Re: programy exe i web server

Post autor: mikema72 » 08 sty 2009 08:43

Jednak się chyba trochę pozmieniało. Po kontakcie z NI otrzymałem wyjaśnienie i taki link

http://digital.ni.com/public.nsf/allkb/ ... enDocument

Mam nadzieję że zadziała będę próbował popołudniu i dam znać...

ODPOWIEDZ