Znaleziono 14 wyników

autor: apb
19 kwie 2018 12:34
Forum: Tematy ogólne
Temat: Nieaktywny przycisk stop
Odpowiedzi: 5
Odsłony: 654

Re: Nieaktywny przycisk stop

Kolejne iteracji pętli while są uruchamiane po wywołaniu eventu. Użyj "żarówki" i zobacz jak wygląda u Ciebie przepływ danych. Wartość "exit" jest wczytywana na początku danej iteracji, późniejsze wciśnięcie przycisku nie powoduje już żadnej akcji. Nawet gdybyś "trwale"zmienił wartość "exit", wyjści...
autor: apb
19 kwie 2018 10:10
Forum: Tematy ogólne
Temat: Kolory wykresu
Odpowiedzi: 8
Odsłony: 1046

Re: Kolory wykresu

Obecnie zawsze na wykresie wyświetlasz wszystkie krzywe, w przypadku ustawienia wartości False nie podajesz żadnych danych dla danej krzywej, więc teoretycznie się ona nie wyświetla. Rozwiń legendę i zmień kolory krzywych - zobaczysz, że odpowiednie kolory były tam już wcześniej ustawione, Set Wavef...
autor: apb
18 kwie 2018 01:02
Forum: Tematy ogólne
Temat: Kolory wykresu
Odpowiedzi: 8
Odsłony: 1046

Re: Kolory wykresu

Poszukaj odpowiedzi w pomocy dostępnej w LabVIEW.
PPM na property node->Help for...
autor: apb
18 kwie 2018 00:22
Forum: Tematy ogólne
Temat: Kolory wykresu
Odpowiedzi: 8
Odsłony: 1046

Re: Kolory wykresu

Możesz skorzystać z property node: PPM na Waveform Graph->Create->Property Node->Plot->Plot Color Wcześniej musisz wybrać dla której krzywej ustawiasz kolor (property node "Active Plot"). W zależności od ilości krzywych odpowiednio zmieniasz kolory. Kolejny sposób to zawsze wyświetlasz 4 wykresy i t...
autor: apb
15 kwie 2018 23:37
Forum: Tematy ogólne
Temat: Obrotomierz samochodowy
Odpowiedzi: 4
Odsłony: 833

Re: Obrotomierz samochodowy

Wrzuć program dla starszej wersji LV (np. 2016).
autor: apb
11 kwie 2018 21:22
Forum: Tematy ogólne
Temat: Symulator panelu fotowoltaicznego.
Odpowiedzi: 14
Odsłony: 3143

Re: Symulator panelu fotowoltaicznego.

Masz źle zapisany wzór dla FF, powinno być tak: FF=Impp*Umpp/(Isc*Uoc); Po co umieszczasz kod w pętli for skoro i tak za każdym razem obliczasz tą samą wartość (stałe wartości wejściowe)? Każde kolejne uruchomienie aplikacji powoduje dodanie dwóch punktów do wykresu (104 i 0,59) dla kolejnych wartoś...
autor: apb
11 kwie 2018 20:43
Forum: Tematy ogólne
Temat: Problem z property node scale fit
Odpowiedzi: 5
Odsłony: 977

Re: Problem z property node scale fit

Już udało mi się to wcześniej w podobny sposób zrobić. Dzięki za pomoc. :) Czy w przypadku OsScaleFit=0 muszę też uaktualniać ScaleFit czy wystarczy tylko uaktualnić wartości max i min? Czy wiesz może czemu w poprzedniej wersji działało to prawidłowo tylko dla osi odciętych? Zmiana kolejności przetw...
autor: apb
09 kwie 2018 19:27
Forum: Tematy ogólne
Temat: Problem z property node scale fit
Odpowiedzi: 5
Odsłony: 977

Re: Problem z property node scale fit

Nie widziałem tamtego tematu - dzięki. Problem z aktualizowaniem się wykresu tylko na aktywnej karcie rozwiązałem poprzez programowe przełączanie kart przed aktualizacją. Teraz z kolei pojawił się z tym inny problem. Automatyczne i ręczne dobieranie zakresu osi odciętych działa bez problemu, natomia...
autor: apb
09 kwie 2018 16:30
Forum: Tematy ogólne
Temat: Problem z property node scale fit
Odpowiedzi: 5
Odsłony: 977

Re: Problem z property node scale fit

Wygląda na to, że udało mi się rozwiązać problem. Przed przetwarzaniem wykresu A przełączam kartę na wykres A, a przed przetwarzaniem B na kartę z wykresem B. Na końcu wracam do pierwotnie wyświetlanej karty. Nie jest to zbyt pięknie zrobione, ale jak na razie działa.
rozwiazanie.PNG
autor: apb
09 kwie 2018 15:10
Forum: Tematy ogólne
Temat: Problem z property node scale fit
Odpowiedzi: 5
Odsłony: 977

Problem z property node scale fit

Cześć Projektuję aplikację, która m.in. umożliwia wyświetlanie wcześniej utworzonych charakterystyk. Chcę dać użytkownikowi możliwość wybrania czy zakres osi X i Y ma być ustalany automatycznie - jeśli nie, użytkownik podaje żądane wartości (zakładka "Tworzenie wykresów"->"Ustawienia wykresu"). Manu...
autor: apb
20 lis 2017 23:11
Forum: Tematy ogólne
Temat: Problem z property node legend autosize
Odpowiedzi: 5
Odsłony: 1637

Re: Problem z property node legend autosize

Zrobiłem to tak:
solution.PNG
solution.PNG (3.75 KiB) Przejrzano 1604 razy
"LegNumRows" wpiąłem przed przetwarzaniem wykresu, dzięki temu dostaję ilość pozycji legendy. Otrzymaną tablicę dołączam do aktualnie używanej tablicy z nazwami krzywych.
autor: apb
20 lis 2017 15:50
Forum: Tematy ogólne
Temat: Problem z property node legend autosize
Odpowiedzi: 5
Odsłony: 1637

Re: Problem z property node legend autosize

Dziękuję za odpowiedź. Jak pisałem wcześniej, część programu wyrzuciłem przed wstawieniem. W trybie "wyłączony" liczba przebiegów zmienia się (program umożliwia m.in. porównywanie wielu powtórzeń z danej serii pomiarowej, dlatego też ilość krzywych nie jest zdefiniowana w Case Structure. Faktycznie,...
autor: apb
20 lis 2017 12:41
Forum: Tematy ogólne
Temat: Problem z property node legend autosize
Odpowiedzi: 5
Odsłony: 1637

Re: Problem z property node legend autosize

Zapisałem jeszcze projekt dla starszej wersji labview:
Aplikacja_charakterystyka_czujnika.rar
(130.43 KiB) Pobrany 55 razy
autor: apb
20 lis 2017 12:38
Forum: Tematy ogólne
Temat: Problem z property node legend autosize
Odpowiedzi: 5
Odsłony: 1637

Problem z property node legend autosize

Cześć. Mam problem z automatycznym dopasowywaniem wielkości legendy poprzez property node. W załączniku wstawiam tylko część kodu (stąd występują puste przestrzenie na front panelu), jednak wszystko co potrzeba zamieściłem. Problem wygląda następująco: Jeśli po odpaleniu programu i jego wykonaniu, z...